Textual description of firstImageUrl

CCNA in Hindi : OSPF configuration

OSPF Configuration 

  • OSPF cost metric in Hindi 
  • Basic OSPF configuration in Hindi 
  • OSPF passive interface configuration in Hindi 
  • OSPF Virtual links configuration in Hindi 

OSPF Cost Metric Formula 

इससे पहले की आप OSPF को configure करना सीखें आइये OSPF metric को समझने का प्रयास करते है।किसी भी destination network तक के लिए best path OSPF cost metric के द्वारा determine करता है। ये cost metric interface की bandwidth पर depend करती है। किसी भी route की total cost सभी interfaces की cost की sum होती है। किसी भी interface में lowest interface को preference दी जाती है। 

सभी प्रकार के interfaces के लिए cost define की गयी है, जो नीचे दी जा रही है। 

Type  
 Cost
Ethernet (10 mbps)
 10
Fast Ethernet (100 mbps)
 1
Serial (56K) 
 1785
Serial (64K)  
 1562
T1 (1.544 mbps)  
 64
       
Serial interfaces पर cost calculate करने के लिए आपको bandwidth configure करनी पड़ती है। जिसे OSPF metric calculate करने के लिए use करता है। किसी भी serial interface पर आप bandwidth इस प्रकार configure कर सकते है। 


RouterA(config)# interface s0
RouterA(config-if)# bandwidth 64

   

किसी भी interface की default cost आप change कर सकते है। इसे आप इस तरह कर सकते है। 


RouterA(config)# interface e0
RouterA(config-if)# ip ospf cost 5

  

जब आप किसी interface की cost को change करते है तो OSPF का route भी change हो जाता है। इसलिए आपको इसे सावधानी से use करना चाहिए।


Basic  OSPF Configuration 

नीचे दिए गए network को देखिये।

OSPF-in-Hindi

यदि आप इस network में OSPF को configure करना चाहते है तो इस प्रकार कर सकते है। सभी routing protocols global configuration mode में configure किये जाते है।



RouterA(config)# router ospf 1
RouterA(config-router)# router id 1.1.1.1
RouterA(config-router)# network 192.17.1.1 0.0.255.255 area 1
RouterA(config-router)# network 192.18.1.1 0.0.255.255 area 0


जैसा की आप देख सकते है। पहली command router ospf 1 है। यँहा पर 1 एक unique process id और ये हर router पर unique भी हो सकती है और same भी हो सकती है। इसके बाद router id command से इस router को एक unique id assign की गयी है। इसके बाद network command से दोनों interfaces को अलग अलग area के साथ configure किया गया है। यँहा पर आपको एक बात ये भी ध्यान रखनी चाहिए की network command में subnet mask भी दिया गया है।

इसी प्रकार router B को भी configure किया जा सकता है।


RouterB(config-)# router ospf 1
RouterB(config-if)# router id 2.2.2.2 
RouterB(config-if)# network 198.19.1.1 0.0.255.225 area 1
RouterB(config-if)# network 198.18.1.1 0.0.255.255 area 0

     

Passive Interface Configuration 

यदि आप चाहते ही की कोई router routing process में हिस्सा न ले तो उस तक जाने वाले interface को आप passive interface बना सकते है। ऐसा करने से वो router किसी दूसरे router के साथ neighbor relationship build नहीं कर सकता है। उस interface से दोनों ही direction में कोई routing updates नहीं जा सकती है। किसी भी interface को passive आप इस प्रकार बना सकते है।  


RouterB(config-router)# passive-interface e0


यदि आप वापस किसी interface को active बनाना चाहते है तो वो आप इस प्रकार कर सकते है। 


RouterB(config-router)# no passive-interface e0 


      DMCA.com Protection Status

2  Replies so far - Add your comment